Problema: Chiusura con bug di LMMS

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso

Problema: Chiusura con bug di LMMS

Messaggio Da Nismo il 25/6/2015, 15:52

Ciao a tutti,

ogni volta che chiudo LMMS compare il messaggio di errore windows "l'applicazione non risponde", volevo sapere se questo comportamento si verifica anche a voi.
Non è un problema reale, dato che si presenta solo in chiusura di LMMS, quando ormai il progetto è salvato e tutto!
Però se è un bug generale potremmo segnalarlo.

Che dite?

Nismo

Posts : 7
Join date : 24.06.15

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da DeRobyJ il 25/6/2015, 16:16

Benvenuto!

No, non mi capita mai, nè ho mai sentito nessuno con questo errore.
Proviamo a risolverlo. Sistema operativo?
avatar
DeRobyJ

Posts : 36
Join date : 19.12.14

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da Nismo il 25/6/2015, 20:10

Windows Vista......purtroppo Laughing

Nismo

Posts : 7
Join date : 24.06.15

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da DeRobyJ il 25/6/2015, 20:24

Ah bhe, non credo di aver mai sentito di qualcuno con vista xD

Nel forum di LMMS non ho trovato topic recenti (ultimi mesi) con questo crash su windows vista. C'è solo un topic in cui il programma crasha in conseguenza all'apertura di progetti.

Ergo potrebbe non dipendere dal sistema operativo.
Tuttavia vediamo se qualcosa può aiutare comunque.

- Hai installato l'ultimo service pack?
- Il tuo sistema è a 32 o 64 bit? E LMMS è come il sistema?


Altri test:
- Hai provato a chiudere attraverso Progetto->Esci?
- Ti accade con tutti i progetti? Prova a creare un nuovo progetto, eliminare tutte le tracce in SongEditor e BBEditor, salvare e chiudere.
- Prova ad aprire due istanze di LMMS (letteralmente aprire l'eseguibile due volte). Se ne chiudi una, crasha solo lei?
- Ci sono altri programmi che lasci aperti mentre usi LMMS?
avatar
DeRobyJ

Posts : 36
Join date : 19.12.14

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da Nismo il 25/6/2015, 20:34

- Ultimo SP installato
- Sistema 32 bit
- LMMS 32 bit
- Ho fatto delle prove, innanzitutto questo bug non si verifica se non apporto modifiche al progetto, o se rimane aperto per poco tempo (molto strano!).
- Chiudo il programma dalla crocetta a sfondo rosso in alto a destra, esce la finestra "save - discard - annulla", premo su discard (quindi non salvo).
- Il bug mi fa chiudere solo una delle due istanze LMMS, ad esempio ho 2 progetti aperti contemporaneamente "prog. 1" e "prog. 2", chiudendo il prog 2 mi da l'errore, quindi faccio la chiusura forzata ma chiude solo la seconda istanza di LMMS, sul prog 1 posso continuare a lavorare
- Accade sia senza che con altri programmi aperti

Nismo

Posts : 7
Join date : 24.06.15

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da DeRobyJ il 25/6/2015, 21:09

Ho la sensazione che sia un problema di liberazione della memoria .-.
Per un qualche motivo il programma non tiene bene traccia della memoria in suo possesso nel tempo, e quando viene chiuso non è in grado di capire quanta liberarne...
Ma questa è fisolofia xD
Tuttavia potresti dirmi quanta RAM hai?

Proviamo altre cose:
- Crea un progetto, aggiungi il plugin ZynAddSubFX (o un suo preset), apri la GUI, chiudi il programma senza chiudere la GUI di Zyn
- Fai la stessa cosa con un VST (se non ne hai mai usati, salta questo passaggio)

Diciamo che o è quello che ho scritto prima, oppure è uno di questi due plugin che non viene chiuso correttamente se deve farlo insieme a tutto il programma
avatar
DeRobyJ

Posts : 36
Join date : 19.12.14

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da Nismo il 25/6/2015, 21:50

Premetto che ZynAddSubFX una volta mi ha fatto crushare il programma.
Comunque ho provato il primo passaggio e niente, se apro LMMS quindi la GUI di Zyn e chiudo il programma tutto in pochi secondi non da l'errore, mentre se aspetto di più il bug c'è. Stessa cosa con vari VST.
Penso sia (e ripeto stranamente) una questione di tempo, se il programma resta aperto per più di x secondi il problema si presenta altrimenti no. scratch
Forse al momento dell'installazione qualche pezzetto di codice non è stato salvato ed ogni volta che chiudo il programma in determinate condizioni si presenta questo problema!
Comunque ti aggiorno se noto qualche correlazione particolare. Smile

Nismo

Posts : 7
Join date : 24.06.15

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da DeRobyJ il 25/6/2015, 23:08

Mm, dici che è questione di tempo...
Sicuramente reistallare non può fare male, ma dubito che sia lì il problema. Magari una pulizia di registro e di cache prima di reistallare...

Un ultimo test che possiamo fare:
- Apri il Task Manager
- Apri LMMS
- Guarda il processo di LMMS: per caso nel tempo succede qualcosa alla memoria usata? Se non si fa alcuna operazione, le variazioni di memoria non dovrebbero superare pochi kilobyte.

Ti faccio fare tutti questi test perchè poi chiederò in mailing list, e lì preferisco scrivere un report completo.
avatar
DeRobyJ

Posts : 36
Join date : 19.12.14

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da Nismo il 26/6/2015, 19:57

L'utilizzo della memoria si dimezza, però penso sia anche normale dato che l'applicazione è in chiusura no?
Comunque ho notato una cosa strana, nei dettagli del bug indica che la mia versione di LMMS è la 1.0.9 mentre io ho la 1.1.3. Sarà una questione di VST datati?

Nismo

Posts : 7
Join date : 24.06.15

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da DeRobyJ il 27/6/2015, 11:45

No, si sono dimenticati di cambiare la versione che il programma pensa di essere. Anche l'audio esportato riporta 1.0.9 nelle etichette.

Per la memoria, intendevo se succedeva qualcosa mentre non facevi nulla, nel tempo!! E' ovvio che quando si spegne diminuisca...

Comunque, provo a scrivere, vediamo se ne ricavo qualcosa...

____________________________

Anche loro non sembrano avere avuto esperienze simili, ma mi hanno consigliato un po' di cose:
- Aggiornare i driver audio
- Cambiare il driver audio usato (sempre che suoni bene)

Ci sono un po' di passaggi che si possono fare, per ora mi hanno detto questi...

____________________________

Ho ricevuto altre risposte, e sembra che ci sia qualcun'altro con lo stesso problema, ma su windows xp
https://github.com/LMMS/lmms/issues/2088

Puoi dare un'occhiata tu stesso, e se ci sono dei passaggi poco chiari per l'inglese puoi chiedere qui. Al momento è stato identificato come bug, e non si otterrà soluzione in tempo breve in quanto mancano strumenti di controllo su windows (e dato che il bug secondo me è solo su windows, non credo riusciranno a ritrovarlo su linux e controllarlo là...)
Pertanto speriamo che nella 1.2 si risolva magicamente xD
avatar
DeRobyJ

Posts : 36
Join date : 19.12.14

Vedere il profilo dell'utente

Tornare in alto Andare in basso

Re: Problema: Chiusura con bug di LMMS

Messaggio Da Contenuto sponsorizzato


Contenuto sponsorizzato


Tornare in alto Andare in basso

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto

- Argomenti simili

 
Permesso di questo forum:
Non puoi rispondere agli argomenti in questo forum